PHP 7 opgraderingsguide

Vi er ved at gøre os nogle erfaringer med PHP7 og diverse CMS, her er en række problemer og løsninger.

mysql extension er fjernet

mysql_* funktionerne er udgået/fjernet i PHP7. Skift til MySQLi funktionerne.

ereg extension er fjernet

Brug preg_* extension i stedet.

WordPress

Vi har ikke set nogle problemer med WordPress. Sørg for både WordPress, plugins og temaer er opdateret.

Magento <=1.9 virker ikke

Der skal rettes en enkelt linje i en enkelt fil, for at Magento 1.9 virker med PHP7.

Guide her: http://www.bubblecode.net/en/2015/07/24/magento-php-7/

Se også http://inchoo.net/magento/its-alive/

Vi anbefaler at alle kunder opgraderer til Magento 2, nedgraderer til PHP 5.6, eller ser ovenstående links.

joomla <=3.4 virker ikke

Joomla 3.4 virker ikke med PHP7, opgrader til Joomla 3.5.

Drupal 7

Drupal 7 virker umiddelbart fint med PHP 7.0. Sørg for du bruger nyeste version af Drupal 7, eller opgrader til Drupal 8.

Concrete5

Concrete5 er desværre langt bagud med PHP 7 understøttelse.

PHP-kode bliver cached

Der er aktiveret opcache på vores PHP7 servere. Opcache gør PHP og dit webhotel enormt hurtig.

Såfremt du ønsker at slå opcache fra, kan det gøres ved at tilføje “php_flag opcache.enable 0” i din .htaccess fil. Som udgangspunkt anbefaler vi IKKE du deaktiverer opcache, men det står dig frit for. Du kan også indstille opcache.revalidate_freq til 0 for at stadig bruge opcache, men fjerne forsinkelsen, dette er en bedre løsning.

Nedgrader til PHP 5.6

På vores PHP 7 webservere er det muligt at nedgradere sit webhotel til PHP 5.6.

Det gøres ved at tilføje “AddType application/x-httpd-php-old .php” i bunden af websidens “.htaccess” fil. Hvis du ingen .htaccess fil har på dit webhotel, kan du blot lave én igennem vores File Manager eller dit FTP program.

Bemærk dette er en midlertidig løsning. På et senere tidspunkt vil dette ikke længere virke (PHP 5.6 bliver end-of-life i 2018).

clya4nh

9 meninger om “PHP 7 opgraderingsguide”

  1. Igen forsimpler i situationen helt grotesk meget… En linie og så kører Magento, ok har i testet alle de moduler der findes derude på jeres php 7 setup?

    Det Cms jeg benytter (SilverStripe) kommer formentligt først i en php7 kompatibelt udgave i Q2 2016.

    Jeg håber meget i forstår alvoren i det her og kommer med et realistisk bud på hvad der skal ske hvis man ikke ønsker PHP7 nu.

    1. Nu er vi ikke kendt for at gøre vores kunder ondt eller træffe dårlige beslutninger, tværimod, så du kan være absolut sikker på at vi gør hvad der er bedst for dig og alle vores kunder.

      Vi har ikke meldt noget endeligt ud om hvornår vi opgraderer gamle kunder til PHP7, eller hvordan det kommer til at foregå.

      1. ” Vi har ikke meldt noget endeligt ud om hvornår vi opgraderer gamle kunder til PHP7, eller hvordan det kommer til at foregå. ”

        Er der noget nyt om dette, kan se dit indlæg er fra december sidste år. Jeg tænker at det vil være dejligt at ens server blev opgraderet, med muligheden for at nedgradere midlertidigt, hvis der skulle være ting der stadig ikke er kompatible (tror alle mine joomla udvidelser er OK nu).

  2. Jeg synes det er fedt, at I er fremme i skoene og opgraderer til nye teknologier forholdsvist hurtigt. Skal man som kunde skrive til jer, hvis man _gerne_ vil med på den nye vogn hurtigst muligt?

  3. Jeg har lige investeret enorme mængder i Magento 1.9, og jeg må nok erkende; at hvis i _FJERNER_ muligheden for at kører PHP5.6, så *finder jeg et andet hosting selvskab*. Jeg har købt tema og investeret i undervisning til personale i Magento, og vi er mere eller mindre klar til at gå i luften, og så skal man til at købe helt nyt Magento 2.0 tema og min medarbejdere skal til en ny backend, det er for meget. Hvis ikke i bibeholder muligheden for PHP5.6, så jeg smuttet

    1. Som beskrevet i artiklen har vi ikke i sinde at fjerne PHP 5.6 før det er forsvarligt.

      Der var også folk der råbte bål og brand om at de altid ville køre PHP 5.3, ellers så ville de finde en anden udbyder. De folk har nok også ændret holdning siden da.

      Formentlig vil du heller ikke køre Magento 1.9 i evigheder, da det også på et tidspunkt vil være uforsvarligt.

Lukket for kommentarer.