Status på PHP 5.6 opdatering

Hermed en kort status på vores PHP 5.6 projekt.

Opdatering udskudt

Vi havde oprindeligt lovet at opgradere vores servere i Oktober/November 2014.
Vi er i mellemtiden blevet meget bekymret for evt. problemer der måtte opstå for kunder midt i det vigtige julesalg. Dette taget i betragtning, og efter nærmere analyse af den nye platform, har vi derfor valgt at udskyde opgraderingen af eksisterende servere til efter jul. Formentlig Januar/Februar. Det vil også give os noget mere tid til at teste den nye platform lidt mere.

Vi er i øjeblikket ved at teste den nye platform sammen med nye kunder, pt. kører det som det skal, men lidt ekstra tid til test vil ikke gøre os noget :) Det er trods alt en kæmpe opdatering af vores platform.

Desværre er Ioncube folkene nådestløst langsomme til at understøtte PHP 5.6,  derfor ser det pt. ud til vi må sænke forventningerne, og starte med at opgradere til PHP 5.5, indtil Ioncube kommer med på vognen. Vejen fra PHP 5.5 til PHP 5.6 skulle også være forholdsvis problemfri, sammenlignet med 5.3 til 5.5.

Vi håber det giver mening, og beklager selvfølgelig over for de folk sidder og venter på PHP 5.6 opdateringen. Der er ikke noget vi hellere vil end at køre 5.6, men vi vil også gerne sikre at den stabilitet, som vi er så kendt for, følger med.

med andre ord…

Planen er derfor at eksisterende servere/kunder/webhoteller ikke bliver opdateret før Januar/Februar. Alle nye webhoteller vil snarest muligt blive oprettet på en PHP 5.5 server (med safe_mode off, osv.). Når Ioncube kommer med 5.6 understøttelse, så opgradere vi til PHP 5.6.

Kunder der virkelig virkelig gerne vil køre PHP 5.5+ hurtigst muligt, kan evt. kontakte vores support og blive flyttet til en PHP 5.5 server, når en sådan kommer i produktion. Dette indlæg vil blive opdateret når det sker.

Opdatering 9/11: Vores første PHP 5.5 server er nu i produktion.

Opdatering 10/11: Ja ok, så var Ioncube lige kommet til 5.6 – så vi kører nu 5.6 i stedet for 5.5. Alt er godt :)

2 thoughts on “Status på PHP 5.6 opdatering”

  1. Vil man i denne forbindelse få problemer i forhold til krav om “mysqli” og “PDO” når man pt benytter den ældre “mysql_connect()” – eller vil der blot komme en fejlmeddelelse i stil med “Deprecated mysql_connect()” ??

    1. Vores standard opsætning er at skjule E_DEPRECATED fejl, så hvis du eller dit CMS ikke har ændret det, så vil du ingen fejl få.

      ‘mysql’ udvidelsen er stadig at finde på vores servere.

Comments are closed.